re = /(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)/m
str = 'thisString
rssTitle
RSSTitle
weLikeFOSS'
subst = ' ${1} $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result