package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)`)
var str = `thisString
rssTitle
RSSTitle
weLikeFOSS`
var substitution = " ${1} $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}