$re = '`(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)`m';
$str = 'thisString
rssTitle
RSSTitle
weLikeFOSS';
$subst = " ${1} $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;