const regex = new RegExp('(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)', 'gm')
const str = `thisString
rssTitle
RSSTitle
weLikeFOSS`;
const subst = ` ${1} $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);