#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^<\W>]div[^<\W>]"
Local $sString = "<div id="div">" & @CRLF & _
"dgdivdivdiv div divdivfgsdfa" & @CRLF & _
"</div>" & @CRLF & _
"<p id="p" >" & @CRLF & _
"pppppppppp p ppphjyerw" & @CRLF & _
"</p><div id="div">" & @CRLF & _
"dgdivdivdivdiv div divfgsdfa" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")