using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^<\W>]div[^<\W>]";
string input = @"<div id=""div"">
dgdivdivdiv div divdivfgsdfa
</div>
<p id=""p"" >
pppppppppp p ppphjyerw
</p><div id=""div"">
dgdivdivdivdiv div divfgsdfa
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}