$re = '/[^<\W>]div[^<\W>]/';
$str = '<div id="div">
dgdivdivdiv div divdivfgsdfa
</div>
<p id="p" >
pppppppppp p ppphjyerw
</p><div id="div">
dgdivdivdivdiv div divfgsdfa
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);