// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^<\W>]div[^<\W>]").unwrap();
let string = "<div id=\"div\">
dgdivdivdiv div divdivfgsdfa
</div>
<p id=\"p\" >
pppppppppp p ppphjyerw
</p><div id=\"div\">
dgdivdivdivdiv div divfgsdfa
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}