re = /[^<\W>]div[^<\W>]/
str = '<div id="div">
dgdivdivdiv div divdivfgsdfa
</div>
<p id="p" >
pppppppppp p ppphjyerw
</p><div id="div">
dgdivdivdivdiv div divfgsdfa
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end