# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^.*StartToken \S+\s| EndToken.*$)//g;t' <<< "WordA1 wordA2 wordAN StartToken Skipword WordB1 WordB2 WordBN EndToken WordV1 WordCN"