package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^.*StartToken \S+\s| EndToken.*$)`)
var str = `WordA1 wordA2 wordAN StartToken Skipword WordB1 WordB2 WordBN EndToken WordV1 WordCN`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}