re = /(?:^.*StartToken \S+\s| EndToken.*$)/
str = 'WordA1 wordA2 wordAN StartToken Skipword WordB1 WordB2 WordBN EndToken WordV1 WordCN'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result