$re = '/(?:^.*StartToken \S+\s| EndToken.*$)/';
$str = 'WordA1 wordA2 wordAN StartToken Skipword WordB1 WordB2 WordBN EndToken WordV1 WordCN';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;