import Foundation
let pattern = #"(?:^.*StartToken \S+\s| EndToken.*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"WordA1 wordA2 wordAN StartToken Skipword WordB1 WordB2 WordBN EndToken WordV1 WordCN"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)