using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bRs\.\d+(\.[^\s\,]\d+)?\b";
string input = @"Rs.192.50 ddddddddddddd
ddd Rs.2,94.00 dddddddddddd
Rs. 250 ddddddd
ddd 50mg ddddddddd
100 days
ddddd 1OO days
20%
dd Rs.100 ssgh
Rs. 10 00 dfy
sdfg Rs.10 00 sdtt
sdf Rs,20 dftr
Rs.10s10 ..li
Rs..10
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}