// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bRs\.\d+(\.[^\s\,]\d+)?\b").unwrap();
let string = "Rs.192.50 ddddddddddddd
ddd Rs.2,94.00 dddddddddddd
Rs. 250 ddddddd
ddd 50mg ddddddddd
100 days
ddddd 1OO days
20%
dd Rs.100 ssgh
Rs. 10 00 dfy
sdfg Rs.10 00 sdtt
sdf Rs,20 dftr
Rs.10s10 ..li
Rs..10
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}