use strict;
my $str = 'Rs.192.50 ddddddddddddd
ddd Rs.2,94.00 dddddddddddd
Rs. 250 ddddddd
ddd 50mg ddddddddd
100 days
ddddd 1OO days
20%
dd Rs.100 ssgh
Rs. 10 00 dfy
sdfg Rs.10 00 sdtt
sdf Rs,20 dftr
Rs.10s10 ..li
Rs..10
';
my $regex = qr/\bRs\.\d+(\.[^\s\,]\d+)?\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}