const regex = /\bRs\.\d+(\.[^\s\,]\d+)?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bRs\\.\\d+(\\.[^\\s\\,]\\d+)?\\b', 'gm')
const str = `Rs.192.50 ddddddddddddd
ddd Rs.2,94.00 dddddddddddd
Rs. 250 ddddddd
ddd 50mg ddddddddd
100 days
ddddd 1OO days
20%
dd Rs.100 ssgh
Rs. 10 00 dfy
sdfg Rs.10 00 sdtt
sdf Rs,20 dftr
Rs.10s10 ..li
Rs..10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}