import re
regex = re.compile(r"\bRs\.\d+(\.[^\s\,]\d+)?\b", flags=re.MULTILINE)
test_str = ("Rs.192.50 ddddddddddddd\n"
"ddd Rs.2,94.00 dddddddddddd\n"
"Rs. 250 ddddddd\n"
"ddd 50mg ddddddddd\n"
"100 days\n"
"ddddd 1OO days\n"
"20%\n"
"dd Rs.100 ssgh\n"
"Rs. 10 00 dfy\n"
"sdfg Rs.10 00 sdtt\n"
"sdf Rs,20 dftr\n"
"Rs.10s10 ..li\n"
"Rs..10\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")