const regex = /(\w+)#/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)#', 'gm')
const str = `public static GameOverImgAlpha#;`;
const subst = `float $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);