use strict;
my $str = 'public static GameOverImgAlpha#;';
my $regex = qr/(\w+)#/mp;
my $subst = 'float $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";