re = /(\w+)#/m
str = 'public static GameOverImgAlpha#;'
subst = 'float $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result