$re = '/(\w+)#/m';
$str = 'public static GameOverImgAlpha#;';
$subst = "float $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;