import re
regex = re.compile(r"(\w+)#", flags=re.MULTILINE)
test_str = "public static GameOverImgAlpha#;"
subst = "float $1"
result = regex.sub(subst, test_str)
if result:
print(result)