using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bUA\s?\d{2}\s?\d{6}\s?\d{19}\b";
string input = @"UA 19 300346 0000000000029242108
UA193003460000000000029242108
UA 193003460000000000029242108
UA293003560000000000029112108
UA083001260000000000029243308
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}