// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bUA\s?\d{2}\s?\d{6}\s?\d{19}\b").unwrap();
let string = "UA 19 300346 0000000000029242108
UA193003460000000000029242108
UA 193003460000000000029242108
UA293003560000000000029112108
UA083001260000000000029243308
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}