const regex = /\bUA\s?\d{2}\s?\d{6}\s?\d{19}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bUA\\s?\\d{2}\\s?\\d{6}\\s?\\d{19}\\b', 'gm')
const str = `UA 19 300346 0000000000029242108
UA193003460000000000029242108
UA 193003460000000000029242108
UA293003560000000000029112108
UA083001260000000000029243308
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}