#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,\h*"
Local $sString = "Test A, Test B, Test C (data1, data1)" & @CRLF & _
"Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E (data1, data1)" & @CRLF & _
"Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E ((data1, data1), data(data, data))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")