using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,\h*";
string input = @"Test A, Test B, Test C (data1, data1)
Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E (data1, data1)
Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E ((data1, data1), data(data, data))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}