re = /(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,\h*/
str = 'Test A, Test B, Test C (data1, data1)
Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E (data1, data1)
Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E ((data1, data1), data(data, data))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end