import Foundation
let pattern = #"(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,\h*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Test A, Test B, Test C (data1, data1)
Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E (data1, data1)
Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E ((data1, data1), data(data, data))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)