$re = '/(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,\h*/';
$str = 'Test A, Test B, Test C (data1, data1)
Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E (data1, data1)
Test A, Test B, Test C (data1, data1), Test D (data1, data1), Test E ((data1, data1), data(data, data))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);