using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)[.](?=\d{3}[.])";
string substitution = @"";
string input = @"[1] ""AA.8.BB.CCCC"" ""2017"" ""3.166.5"" ""3.080.2"" ""68"" ""162.6""
[7] ""185.223.632.4"" ""500.332.1"" ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}