import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d)[.](?=\\d{3}[.])";
final String string = "[1] \"AA.8.BB.CCCC\" \"2017\" \"3.166.5\" \"3.080.2\" \"68\" \"162.6\" \n"
+ "[7] \"185.223.632.4\" \"500.332.1\" ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}