import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(.+)>([0-9-\\s()+]+)<\\/(.+)>";
final String string = "<div id=\"Only456\">(555) 555-1212</div>\n"
+ "<h1>+1 800 555-1212</h1>\n"
+ "<span class=\"row\">555-555-1212</span>";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}