# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(.+)>([0-9-\s()+]+)<\/(.+)>"
test_str = ("<div id=\"Only456\">(555) 555-1212</div>\n"
"<h1>+1 800 555-1212</h1>\n"
"<span class=\"row\">555-555-1212</span>")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.