const regex = /<(.+)>([0-9-\s()+]+)<\/(.+)>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(.+)>([0-9-\\s()+]+)<\\\/(.+)>', 'gm')
const str = `<div id="Only456">(555) 555-1212</div>
<h1>+1 800 555-1212</h1>
<span class="row">555-555-1212</span>`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);