use strict;
my $str = '<div id="Only456">(555) 555-1212</div>
<h1>+1 800 555-1212</h1>
<span class="row">555-555-1212</span>';
my $regex = qr/<(.+)>([0-9-\s()+]+)<\/(.+)>/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";