using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!RSBO|RRABO|RSISTA0).)*$";
string input = @"RSBO
FOORSBO
RSBOFOO
FOORSBOBAR
RRABO
FOORRABO
RRABOFOO
FOORRABOBAR
RSISTA0
FOORSISTA0
RSISTA0FOO
FOORSISTA0BAR
THIS_MATCHES";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}