const regex = /^(?:(?!RSBO|RRABO|RSISTA0).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!RSBO|RRABO|RSISTA0).)*$', 'gm')
const str = `RSBO
FOORSBO
RSBOFOO
FOORSBOBAR
RRABO
FOORRABO
RRABOFOO
FOORRABOBAR
RSISTA0
FOORSISTA0
RSISTA0FOO
FOORSISTA0BAR
THIS_MATCHES`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}