import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!RSBO|RRABO|RSISTA0).)*$";
final String string = "RSBO\n"
+ "FOORSBO\n"
+ "RSBOFOO\n"
+ "FOORSBOBAR\n"
+ "RRABO\n"
+ "FOORRABO\n"
+ "RRABOFOO\n"
+ "FOORRABOBAR\n"
+ "RSISTA0\n"
+ "FOORSISTA0\n"
+ "RSISTA0FOO\n"
+ "FOORSISTA0BAR\n"
+ "THIS_MATCHES";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}