re = /^(?:(?!RSBO|RRABO|RSISTA0).)*$/m
str = 'RSBO
FOORSBO
RSBOFOO
FOORSBOBAR
RRABO
FOORRABO
RRABOFOO
FOORRABOBAR
RSISTA0
FOORSISTA0
RSISTA0FOO
FOORSISTA0BAR
THIS_MATCHES'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end