#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:username|Email|Url):? *\K\V+"
Local $sString = "Username:admin" & @CRLF & _
"Email: admin@test.com" & @CRLF & _
"Url: https://www.admin.com" & @CRLF & _
"" & @CRLF & _
"Username test" & @CRLF & _
"Email test@test.com" & @CRLF & _
"Url https://www.test.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")