import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:username|Email|Url):? *\\K\\V+";
final String string = "Username:admin\n"
+ "Email: admin@test.com\n"
+ "Url: https://www.admin.com\n\n"
+ "Username test\n"
+ "Email test@test.com\n"
+ "Url https://www.test.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}