const regex = /^(?:username|Email|Url):? *\K\V+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:username|Email|Url):? *\\K\\V+', 'gmi')
const str = `Username:admin
Email: admin@test.com
Url: https://www.admin.com
Username test
Email test@test.com
Url https://www.test.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}