$re = '/^(?:username|Email|Url):? *\K\V+/mi';
$str = 'Username:admin
Email: admin@test.com
Url: https://www.admin.com
Username test
Email test@test.com
Url https://www.test.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);