using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:username|Email|Url):? *\K\V+";
string input = @"Username:admin
Email: admin@test.com
Url: https://www.admin.com
Username test
Email test@test.com
Url https://www.test.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}