package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`rel=['"](?:shortcut )?icon['"] href=['"]([^?'"]+)[?'"]`)
var str = `<link rel="shortcut icon" href="https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196">
<link rel="icon" href="https://www.ecotechie.io/wp-content/uploads/2019/05/cropped-EcoTechie-Logo-512x512-1-32x32.png" sizes="32x32" />
<link rel="icon" href="//ssl.gstatic.com/pagespeed/insights/ui/logo/favicon_48.png" sizes="48x48">
<link rel='shortcut icon' href='https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196'>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}