import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "rel=['\"](?:shortcut )?icon['\"] href=['\"]([^?'\"]+)[?'\"]";
final String string = "<link rel=\"shortcut icon\" href=\"https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196\">\n"
+ "<link rel=\"icon\" href=\"https://www.ecotechie.io/wp-content/uploads/2019/05/cropped-EcoTechie-Logo-512x512-1-32x32.png\" sizes=\"32x32\" />\n"
+ "<link rel=\"icon\" href=\"//ssl.gstatic.com/pagespeed/insights/ui/logo/favicon_48.png\" sizes=\"48x48\">\n"
+ "<link rel='shortcut icon' href='https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196'>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}