// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"rel=['"](?:shortcut )?icon['"] href=['"]([^?'"]+)[?'"]"#).unwrap();
let string = "<link rel=\"shortcut icon\" href=\"https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196\">
<link rel=\"icon\" href=\"https://www.ecotechie.io/wp-content/uploads/2019/05/cropped-EcoTechie-Logo-512x512-1-32x32.png\" sizes=\"32x32\" />
<link rel=\"icon\" href=\"//ssl.gstatic.com/pagespeed/insights/ui/logo/favicon_48.png\" sizes=\"48x48\">
<link rel='shortcut icon' href='https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196'>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}